Issues with compatibility on Google Play Store

Follow

DigiCal should be compatible with almost every Android device, the only requirements we have set is that the device has a touch screen and it is running on Android 2.3.3+.

The manufacturer probably made an error configuring the device capabilities for Google Play Store, please contact them for assistance as there is nothing we can do about this problem on our side.

 

Have more questions? Submit a request

Comments

Powered by Zendesk